Чат неактивен

Скорая компьютерная Помощь!

Ремонт,настройка ,установка ПО,диагностика компьютеров!
Спутниковае ТВ : Ямал Радуга-ТВ Триколор НТВ+ Спутниковый интернет.
+79058352107

0 0 vote
Article Rating
Поделитесь публикацией
Запись опубликована в Без рубрики. Закладка ссылка.
Subscribe
Уведомлять
14 Комментарий
самые старые
самые новые наиболее популярные
Inline Feedbacks
View all comments
Epsilon
11 лет назад

А где город ? )

Авмор
Авмор
10 лет назад

Здравствуйте, помогите пожалуйста. Программа печатает ценники на одном листе в 2 столбика и в 6 рядов. А надо чтобы в 8 столбиков и в 2 ряда. Что надо изменить в ниже написанном тексте? Спасибо за ответ. //****************************************************************************** // ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд) // // Параметры: // Таб – таблица, в которую выполняется вывод ценника // ПечНаименование – наименование товара // ПечЕдиница – единица измерения товара // ПечРозн – цена товара // Столбик – номер столбика. // Ряд – номер ряда // // Возвращаемое значение: // Нет. // // Описание: // Добавляет ценник в таблицу. // Процедура ДобавитьЦенник(Таб,… Дальше »

Epsilon
10 лет назад

О Бозе… 1Сэ )))) Кто знает 1Сэ ?)))

Epsilon
10 лет назад

Я конечно 1Сэ не знаю, но интуитивно предполагаю, что функция ДобавитьЦенник() должна выглядеть приблизительно так
(изменённое выделено):

————————>8—————————————————————————————-

Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)

Столбик = ?(Столбик < 7, Столбик + 1 , 0 );
Ряд = ?(Столбик = 0, Ряд + 1, Ряд );

Если Ряд > 2 Тогда
Таб.НоваяСтраница();
Ряд = 1;
КонецЕсли;

Если Столбик = 0 Тогда
Таб.ВывестиСекцию(“Товар|Ценник”);
Иначе
Таб.ПрисоединитьСекцию(“Товар|Ценник”);
КонецЕсли;

КонецПроцедуры // ДобавитьЦенник()

————————>8—————————————————————————————-

Кто реально знает 1Сэ, поправьте, если что не так ))

Jan4ik
10 лет назад

oj…interesno…
a 4to takoe “1Сэ”???
eto takaja programma???

Epsilon
10 лет назад

“1Сэ” – это такая российская фирма, разрабатывающая всякие бухгалтерские и управленческие программы. Вообще она называется “1С”, но 1Сэ прикольнее.
Также эта фирма имела неосторожность разработать свой собственный язык программирования, похожий на Basic, только переведённый на русский язык :lol: пример которого Вы можете наблюдать в третьем посте данной темы… ;-)

Jan4ik
10 лет назад

o4en’ mnogo bykw….neprawdali???….o4en’ poxozhe na MATLAB….xotja prinzip raboti nawernoe y wsex odinakowij…

Epsilon
10 лет назад

В MATLAB тоже применяется модификация BASIC’а, вот почему так похожи языки 1C и MATLAB Имеется ряд языков с похожей семантикой, и хотя не все они являются смысловым наследием BASIC, внешне они напоминают друг друга. Однако в наше время более популярными являются языки-наследники языка Си (“C”). К ним относятся C++, C#, Java, JavaScript, PHP (на котором написан наш сайт) и ряд других. Вот, например, кусок кода на языке С, выполняющий ту же функцию, что и приведённый Аней в 3м сообщении топика (для простоты я взял только первую функцию). Язык C изначально был и является по сей день основным языком в операционках… Дальше »

Jan4ik
10 лет назад

“Epsilon”:
Вобщем, языки программирования – это интересно и на эту тему я могу писать до утра ))))

kak ja wam zawidyjy :oh: ….a mne po4emy to eto programmirowanie nikak ne daetsja :sorry: …..

Epsilon
10 лет назад

“Jan4ik”:kak ja wam zawidyjy ….a mne po4emy to eto programmirowanie nikak ne daetsja ….. Программить просто, если понять суть. Надо научиться думать “по-программистски”. Кстати, очень полезный навык, пригождается и в других областях. Семантика языка не значит почти ничего, это просто набор запоминаемых правил конкретного языка. Главное в программировании – умение проектировать алгоритмы. Представьте, что управляете каким-нибудь небольшим роботом. Вы можете давать ему команды, которые он безукоризненно управляет. Для глубины ощущения можно представлять, что этот робот – Вы сами) Теперь представьте, что Вам дана цель – конечное состояние. Далее начинаете думать – как, пользуясь только набором команд, которые Вам известны, достичь… Дальше »

Авмор
Авмор
10 лет назад

На одном листе выходит:
а а а а
а а а а
а а а а

, а на следующем:
а а а
а а а а
а а а а

В четвертом столбце печатается половина ценника на первом листе, а вторя половина ценника на втором листе.
Эти ценники занимают только первую половину листа, а остальная чистая.

Epsilon
10 лет назад

Интересный эффект о_О

А может, ценники не влезают по ширине и поэтому переносятся на следующий лист ? Или они и по ширине и по высоте половину листа только занимают ?

Авмор
Авмор
10 лет назад

Они влезают, но между ними расстояние большое. А его не должно быть. Между ними не должно быть расстояния.

Epsilon
10 лет назад

Видимо, это расстояние задаётся не при формировании, а непосредственно при выводе. Тот кусок, что ты прислала – это формирование. Думаю, надо смотреть какой-то метод объекта Таб, который непосредственно за вывод отвечает. Могу предположить, что это Таб.ВывестиСекцию(); или Таб.ПрисоединитьСекцию(“Товар|Ценник”); или что-то в этом духе – надо смотреть… Там должна быть печать одного ценника, а потом сдвиг координат вправо на некоторое расстояние – вот его надо уменьшать.